using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bpies osa\W*(\w+\s+\d+)";
string input = @"pies osa. Pszczol 10, miod mis kon, pies osa. Kon 15";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}