package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bpies osa\W*(\w+\s+\d+)`)
var str = `pies osa. Pszczol 10, miod mis kon, pies osa. Kon 15`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}