const regex = /\bpies osa\W*(\w+\s+\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bpies osa\\W*(\\w+\\s+\\d+)', 'g')
const str = `pies osa. Pszczol 10, miod mis kon, pies osa. Kon 15`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}