$re = '/\bpies osa\W*(\w+\s+\d+)/';
$str = 'pies osa. Pszczol 10, miod mis kon, pies osa. Kon 15';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);