package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`/user/(?P<user>[^/]+)/(?P<action>[^/]+)`)
var str = `/user/someone/news`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}