$re = '//user/(?P<user>[^/]+)/(?P<action>[^/]+)/';
$str = '/user/someone/news';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);