const regex = //user/(?P<user>[^/]+)/(?P<action>[^/]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\/user\/(?P<user>[^\/]+)\/(?P<action>[^\/]+)', '')
const str = `/user/someone/news`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}