using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-E])([A-C])([0-2])(\d)([0-5])(\d)([B])(\d{6})([A-Z0-9]{2})(\d{3})$";
string input = @"BA1541B0098362B043";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}