// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([A-E])([A-C])([0-2])(\d)([0-5])(\d)([B])(\d{6})([A-Z0-9]{2})(\d{3})$").unwrap();
let string = "BA1541B0098362B043";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}