import Foundation
let pattern = #"^([A-E])([A-C])([0-2])(\d)([0-5])(\d)([B])(\d{6})([A-Z0-9]{2})(\d{3})$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"BA1541B0098362B043"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}