const regex = /^([A-E])([A-C])([0-2])(\d)([0-5])(\d)([B])(\d{6})([A-Z0-9]{2})(\d{3})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-E])([A-C])([0-2])(\\d)([0-5])(\\d)([B])(\\d{6})([A-Z0-9]{2})(\\d{3})$', '')
const str = `BA1541B0098362B043`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}