using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:( )(?=\1))+";
string substitution = @"";
string input = @"<p>The quick fox</p>""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}