import re
regex = re.compile(r"(?:( )(?=\1))+")
test_str = "<p>The quick fox</p>\""
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)