#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<\/?script.*\/?>(.*<\/script>)?"
Local $sString = "asdf<script>qwer</script>zxcv" & @CRLF & _
"" & @CRLF & _
"/><script/> asdf" & @CRLF & _
"asdf><script />asdf" & @CRLF & _
"asdf> <script asdf/> a" & @CRLF & _
"a <script asdf=asdf/><asdf" & @CRLF & _
"asdf<script asdf=asdf /> <asdf" & @CRLF & _
"asdf<script asdf=asdf a/>" & @CRLF & _
"" & @CRLF & _
"<script>" & @CRLF & _
"alert();" & @CRLF & _
"</script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")