package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<\/?script.*\/?>(.*<\/script>)?`)
var str = `asdf<script>qwer</script>zxcv
/><script/> asdf
asdf><script />asdf
asdf> <script asdf/> a
a <script asdf=asdf/><asdf
asdf<script asdf=asdf /> <asdf
asdf<script asdf=asdf a/>
<script>
alert();
</script>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}