import re
regex = re.compile(r"<\/?script.*\/?>(.*<\/script>)?", flags=re.IGNORECASE)
test_str = ("asdf<script>qwer</script>zxcv\n\n"
"/><script/> asdf\n"
"asdf><script />asdf\n"
"asdf> <script asdf/> a\n"
"a <script asdf=asdf/><asdf\n"
"asdf<script asdf=asdf /> <asdf\n"
"asdf<script asdf=asdf a/>\n\n"
"<script>\n"
"alert();\n"
"</script>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")