import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\/?script.*\\/?>(.*<\\/script>)?";
final String string = "asdf<script>qwer</script>zxcv\n\n"
+ "/><script/> asdf\n"
+ "asdf><script />asdf\n"
+ "asdf> <script asdf/> a\n"
+ "a <script asdf=asdf/><asdf\n"
+ "asdf<script asdf=asdf /> <asdf\n"
+ "asdf<script asdf=asdf a/>\n\n"
+ "<script>\n"
+ "alert();\n"
+ "</script>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}