#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*<div.*>\s*(.*)\s*<\/div>"
Local $sString = "<html>" & @CRLF & _
" <head>" & @CRLF & _
" <head>" & @CRLF & _
" <body>" & @CRLF & _
" <div class="content">" & @CRLF & _
" <div class="profile-info">" & @CRLF & _
" bla bla" & @CRLF & _
" </div>" & @CRLF & _
" <div class="post-content">" & @CRLF & _
" blabla" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")