const regex = /.*<div.*>\s*(.*)\s*<\/div>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*<div.*>\\s*(.*)\\s*<\\\/div>', 'g')
const str = `<html>
<head>
<head>
<body>
<div class="content">
<div class="profile-info">
bla bla
</div>
<div class="post-content">
blabla
</div>
</div>
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}