// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*<div.*>\s*(.*)\s*<\/div>").unwrap();
let string = "<html>
<head>
<head>
<body>
<div class=\"content\">
<div class=\"profile-info\">
bla bla
</div>
<div class=\"post-content\">
blabla
</div>
</div>
</body>
</html>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}