$re = '/.*<div.*>\s*(.*)\s*<\/div>/';
$str = '<html>
<head>
<head>
<body>
<div class="content">
<div class="profile-info">
bla bla
</div>
<div class="post-content">
blabla
</div>
</div>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);