package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((http|https|ftp):\/\/([a-zA-Z0-9\.\-\_\%]+\/?){1}([a-zA-Z0-9\.\-\_]+\/?)*(\?[a-zA-Z0-9\.\-\_\%\+\=\&\:]*)*)`)
var str = `#RosettaAreWeThereYet TT @ESA_Rosetta
Plus qu'une semaine, @Philae2014! http://t.co/zLXrg0t6fv
http://www.godsavethegeek.com/autre/expression-reguliere-regex-pour-les-url
https://www.google.fr/search?q=regex+url&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:fr:official&client=firefox-a&channel=fflb&gfe_rd=cr&ei=XYvbU8qQKsPH8gf5mYDIDQ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}