import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((http|https|ftp):\\/\\/([a-zA-Z0-9\\.\\-\\_\\%]+\\/?){1}([a-zA-Z0-9\\.\\-\\_]+\\/?)*(\\?[a-zA-Z0-9\\.\\-\\_\\%\\+\\=\\&\\:]*)*)";
final String string = "#RosettaAreWeThereYet TT @ESA_Rosetta\n"
+ "Plus qu'une semaine, @Philae2014! http://t.co/zLXrg0t6fv\n\n"
+ "http://www.godsavethegeek.com/autre/expression-reguliere-regex-pour-les-url\n\n"
+ "https://www.google.fr/search?q=regex+url&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:fr:official&client=firefox-a&channel=fflb&gfe_rd=cr&ei=XYvbU8qQKsPH8gf5mYDIDQ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}