import re
regex = re.compile(r"((http|https|ftp):\/\/([a-zA-Z0-9\.\-\_\%]+\/?){1}([a-zA-Z0-9\.\-\_]+\/?)*(\?[a-zA-Z0-9\.\-\_\%\+\=\&\:]*)*)", flags=re.IGNORECASE)
test_str = ("#RosettaAreWeThereYet TT @ESA_Rosetta\n"
"Plus qu'une semaine, @Philae2014! http://t.co/zLXrg0t6fv\n\n"
"http://www.godsavethegeek.com/autre/expression-reguliere-regex-pour-les-url\n\n"
"https://www.google.fr/search?q=regex+url&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:fr:official&client=firefox-a&channel=fflb&gfe_rd=cr&ei=XYvbU8qQKsPH8gf5mYDIDQ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")