const regex = /((http|https|ftp):\/\/([a-zA-Z0-9\.\-\_\%]+\/?){1}([a-zA-Z0-9\.\-\_]+\/?)*(\?[a-zA-Z0-9\.\-\_\%\+\=\&\:]*)*)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((http|https|ftp):\\\/\\\/([a-zA-Z0-9\\.\\-\\_\\%]+\\\/?){1}([a-zA-Z0-9\\.\\-\\_]+\\\/?)*(\\?[a-zA-Z0-9\\.\\-\\_\\%\\+\\=\\&\\:]*)*)', 'ig')
const str = `#RosettaAreWeThereYet TT @ESA_Rosetta
Plus qu'une semaine, @Philae2014! http://t.co/zLXrg0t6fv
http://www.godsavethegeek.com/autre/expression-reguliere-regex-pour-les-url
https://www.google.fr/search?q=regex+url&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:fr:official&client=firefox-a&channel=fflb&gfe_rd=cr&ei=XYvbU8qQKsPH8gf5mYDIDQ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}