import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![^'\\-_\\n]*['\\-_][^'\\-_\\n]*['\\-_])[a-z .',-_]+$";
final String string = "It should be valid if a Surname is:\n"
+ "abcd\n"
+ "abcd'efg\n"
+ "abcd-efg\n"
+ "abcd, .efg\n"
+ "etc...\n\n"
+ "I also need to test if symbols do not repeat... so for example:\n\n"
+ "abcd''efg\n"
+ "abcd-',\n\n"
+ "Are invalid but the one:\n\n"
+ "abcd, .efg\n\n"
+ "Can be valid.\n\n"
+ "At the moment I just created this:\n\n"
+ "^[a-z .',-_]+$\n"
+ "And now I'm trying to check for all the double symbols but I cannot go ahead successfully.\n\n"
+ "Mc'Millan, .jr";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}