use strict;
my $str = 'It should be valid if a Surname is:
abcd
abcd\'efg
abcd-efg
abcd, .efg
etc...
I also need to test if symbols do not repeat... so for example:
abcd\'\'efg
abcd-\',
Are invalid but the one:
abcd, .efg
Can be valid.
At the moment I just created this:
^[a-z .\',-_]+$
And now I\'m trying to check for all the double symbols but I cannot go ahead successfully.
Mc\'Millan, .jr';
my $regex = qr/^(?![^'\-_\n]*['\-_][^'\-_\n]*['\-_])[a-z .',-_]+$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}