const regex = /^(?![^'\-_\n]*['\-_][^'\-_\n]*['\-_])[a-z .',-_]+$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![^\'\\-_\\n]*[\'\\-_][^\'\\-_\\n]*[\'\\-_])[a-z .\',-_]+$', 'gmi')
const str = `It should be valid if a Surname is:
abcd
abcd'efg
abcd-efg
abcd, .efg
etc...
I also need to test if symbols do not repeat... so for example:
abcd''efg
abcd-',
Are invalid but the one:
abcd, .efg
Can be valid.
At the moment I just created this:
^[a-z .',-_]+\$
And now I'm trying to check for all the double symbols but I cannot go ahead successfully.
Mc'Millan, .jr`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}