re = /^(?![^'\-_\n]*['\-_][^'\-_\n]*['\-_])[a-z .',-_]+$/mi
str = 'It should be valid if a Surname is:
abcd
abcd\'efg
abcd-efg
abcd, .efg
etc...
I also need to test if symbols do not repeat... so for example:
abcd\'\'efg
abcd-\',
Are invalid but the one:
abcd, .efg
Can be valid.
At the moment I just created this:
^[a-z .\',-_]+$
And now I\'m trying to check for all the double symbols but I cannot go ahead successfully.
Mc\'Millan, .jr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end