const regex = /[^~\r\n]*~(\d{1,2}-\d{1,2}-\d{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^~\\r\\n]*~(\\d{1,2}-\\d{1,2}-\\d{4})', 'gm')
const str = `Ram~01-01-2019
Ram~1-1-2019
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}