$re = '/[^~\r\n]*~(\d{1,2}-\d{1,2}-\d{4})/m';
$str = 'Ram~01-01-2019
Ram~1-1-2019
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);