// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^~\r\n]*~(\d{1,2}-\d{1,2}-\d{4})").unwrap();
let string = "Ram~01-01-2019
Ram~1-1-2019
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}