import re
regex = re.compile(r"[^~\r\n]*~(\d{1,2}-\d{1,2}-\d{4})", flags=re.MULTILINE)
test_str = ("Ram~01-01-2019\n"
"Ram~1-1-2019\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")