const regex = new RegExp('^([A-Za-z0-9$/#]+?)[/_].*', 'gm')
const str = `#Tableau_6_sid:15251a_4i_2a
/15722c29d_PhotoImageCameraPro
JAVA/15722c29d_PhotoImageqeeee
ABC_CUST_INFO_D
BBC_CUST_ENTRY_F
FHS_PRDCT_STST_T
GHS_INVTR_CD_DRY`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);