re = /^([A-Za-z0-9$\/#]+?)[\/_].*/m
str = '#Tableau_6_sid:15251a_4i_2a
/15722c29d_PhotoImageCameraPro
JAVA/15722c29d_PhotoImageqeeee
ABC_CUST_INFO_D
BBC_CUST_ENTRY_F
FHS_PRDCT_STST_T
GHS_INVTR_CD_DRY'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result