import re
regex = re.compile(r"^([A-Za-z0-9$/#]+?)[/_].*", flags=re.MULTILINE)
test_str = ("#Tableau_6_sid:15251a_4i_2a\n"
"/15722c29d_PhotoImageCameraPro\n"
"JAVA/15722c29d_PhotoImageqeeee\n"
"ABC_CUST_INFO_D\n"
"BBC_CUST_ENTRY_F\n"
"FHS_PRDCT_STST_T\n"
"GHS_INVTR_CD_DRY")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)