use strict;
my $str = '#Tableau_6_sid:15251a_4i_2a
/15722c29d_PhotoImageCameraPro
JAVA/15722c29d_PhotoImageqeeee
ABC_CUST_INFO_D
BBC_CUST_ENTRY_F
FHS_PRDCT_STST_T
GHS_INVTR_CD_DRY';
my $regex = qr`^([A-Za-z0-9$/#]+?)[/_].*`mp;
my $subst = '\\1';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";