using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=www\..+\.org\/\d{6}$).+";
string input = @"www.example.org/123456
www.example.org/1234567
www.example.org/12345
https://www.example.org/124543";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}