$re = '/(?=www\..+\.org\/\d{6}$).+/m';
$str = 'www.example.org/123456
www.example.org/1234567
www.example.org/12345
https://www.example.org/124543';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);