import re
regex = re.compile(r"(?=www\..+\.org\/\d{6}$).+", flags=re.MULTILINE)
test_str = ("www.example.org/123456\n"
"www.example.org/1234567\n"
"www.example.org/12345\n"
"https://www.example.org/124543")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")