const regex = /(?=www\..+\.org\/\d{6}$).+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=www\\..+\\.org\\\/\\d{6}$).+', 'gm')
const str = `www.example.org/123456
www.example.org/1234567
www.example.org/12345
https://www.example.org/124543`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}