# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/src[\\/]main\\/?(?:[^\\/]+\\/?)*.java$//s;t' <<< "src/main/package/one/ClassA.java
"