use strict;
my $str = 'src/main/package/one/ClassA.java
';
my $regex = qr/src[\/]main\/?(?:[^\/]+\/?)*.java$/sp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";