const regex = /src[\/]main\/?(?:[^\/]+\/?)*.java$/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('src[\\\/]main\\\/?(?:[^\\\/]+\\\/?)*.java$', 's')
const str = `src/main/package/one/ClassA.java
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);