$re = '/src[\/]main\/?(?:[^\/]+\/?)*.java$/s';
$str = 'src/main/package/one/ClassA.java
';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;