using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(href=.?)(https?:\/\/[^\""\'\>]+)";
string input = @"<a href=http://asecuritysite.com>Link</a>
<a href=https://www.sans.org/webcasts/archive/2013>Link</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}