package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(href=.?)(https?:\/\/[^\"\'\>]+)`)
var str = `<a href=http://asecuritysite.com>Link</a>
<a href=https://www.sans.org/webcasts/archive/2013>Link</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}