re = /(href=.?)(https?:\/\/[^\"\'\>]+)/
str = '<a href=http://asecuritysite.com>Link</a>
<a href=https://www.sans.org/webcasts/archive/2013>Link</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end