$re = '/(href=.?)(https?:\/\/[^\"\'\>]+)/';
$str = '<a href=http://asecuritysite.com>Link</a>
<a href=https://www.sans.org/webcasts/archive/2013>Link</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);