#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{1}[A-Z]{1}-[A-Z]{1}[0,2,4,6,8]{4}-[1-9]{1}[0-2]{0,1}"
Local $sString = "1A-B1234-19" & @CRLF & _
"1A-B0204-12" & @CRLF & _
"1A-B0204-c" & @CRLF & _
"11-B0204-12" & @CRLF & _
"1A-B2228-0" & @CRLF & _
"1A-B2228-1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")